Задача о назначениях

является частным случаем транспортной задачи. Она имеет такую же структуру, но обладает некоторыми особенностями.

В простейшем  случае задачу о назначениях можно сформулировать следующим образом. Имеется  несколько различных видов работ и столько  же сотрудников.  На каждый вид работы назначается один сотрудник. Каждый из сотрудников может выполнить любую работу, но при этом различаются оплаты сотрудников и время выполнения ими работ. Необходимо распределить работы между сотрудниками таким образом, чтобы минимизировать денежные затраты или время выполнения работ. Так же как и транспортная задача, задача о назначениях может быть сбалансированной  или несбалансированной.

Сбалансированная задача о назначениях

На рис. 10.1 представлены  исходные  данные  задачи  о назначениях. Стоимость  выполнения каждого вида работ занесена в ячейки  B3:F7. Изменяемыми значениями  являются ячейки  B10:F14. В ячейках  B16:F16 находятся  ограничения необходимого  количества  бригад для выполнения каждого вида работ. В данном примере для выполнения любого вида работ требуется одна бригада.

Особенность задачи такого рода заключается в том, что изменяемые значения могут принимать только целочисленные значения  0 и 1. Такие значения  соответствуют  отказу или участию бригады в работе данного вида.

При  вычислении общей стоимости  работ (ячейка F18) использована формула

=СУММПРОИЗВ(B3:F7;B10:F14).

ПРИМЕЧАНИЕ

Функция СУММПРОИЗ Excel вычисляет сумму произведений соответствующих элементов нескольких массивов.

На рис. 10.2 показаны  ограничения, используемые при решении задачи. В этом случае  производится поиск  минимального значения целевой  функции (ячейка F18). Ограничения для ячеек B10:F14 (двоичные значения) вводятся  обычным способом (рис. 10.3).

Рис. 10.1. Исходные данные задачи о назначениях

Рис. 10.2. Ограничения при поиске решения задачи о назначениях

Рис. 10.8. Решение задачи о назначениях с дополнительными условиями

Источник: Трусов А. Ф. Excel 2007 для менеджеров и экономистов: логистические,  производственные и оптимизационные расчеты (+CD). — СПб.: Питер, 2009. — 256 с.: ил.

Похожие посты:

Вы можете оставить комментарий, или ссылку на Ваш сайт.

Оставить комментарий